Home > Apache > | CentOS > | HXP > Apache 2.2 「_(アンダーバー)」対策

Apache 2.2 「_(アンダーバー)」対策

答えから書くと、ダウングレード(ロールバック)にて解決としました。
セキュリティ面から言えばNGですが、取り敢えず次期大幅改造?改良?されるまではコレで運用していくことにします。
もちろん下記施工に当たっては自動アップデートからの除外をお忘れなく!!

ダウングレード方法

まずはダウングレードが可能かを確認。

# yum --showduplicate list httpd*

ココに出ていれば可能の様です。
バージョンが上のものも出ているけど気にしない。

# yum --showduplicate list httpd*
インストール済みパッケージ
httpd.x86_64                                                  2.2.15-60.el6.centos.4                      @updates
httpd-devel.x86_64                                            2.2.15-60.el6.centos.4                      @updates
httpd-tools.x86_64                                            2.2.15-60.el6.centos.4                      @updates
利用可能なパッケージ
httpd.x86_64                                                  2.2.15-59.el6.centos                        base
httpd.x86_64                                                  2.2.15-60.el6.centos.4                      updates
httpd-devel.i686                                              2.2.15-59.el6.centos                        base
httpd-devel.x86_64                                            2.2.15-59.el6.centos                        base
httpd-devel.i686                                              2.2.15-60.el6.centos.4                      updates
httpd-devel.x86_64                                            2.2.15-60.el6.centos.4                      updates
httpd-manual.noarch                                           2.2.15-59.el6.centos                        base
httpd-manual.noarch                                           2.2.15-60.el6.centos.4                      updates
httpd-tools.x86_64                                            2.2.15-59.el6.centos                        base
httpd-tools.x86_64                                            2.2.15-60.el6.centos.4                      updates
httpd24.x86_64                                                1.1-5.el6                                   centos-sclo-rh
httpd24.x86_64                                                1.1-14.el6                                  centos-sclo-rh
(以下略

改めて、ダウングレードさせたいパッケージを指定して実行します。

# yum downgrade httpd httpd-devel httpd-tools mod_ssl

SSLは依存性解決エラーの為に入れました。
改めて確認すると、同時にアップデートされていましたので。

追記: 期間中は、 Logwatch からのメールも 「 was considered unsolicited bulk e-mail (UBE). 〜 Delivery of the email was stopped! 」 となり、届いていませんでした!!

参考リンク
http://hacknote.jp/archives/5946/

Comments:0

Comment Form

Trackbacks:0

TrackBack URL for this entry
https://www.hxp.jp/cgi-bin/mt/mt-tb.cgi/167
Listed below are links to weblogs that reference
Apache 2.2 「_(アンダーバー)」対策 from Minase's Blog - HXP

Home > Apache > | CentOS > | HXP > Apache 2.2 「_(アンダーバー)」対策

Search
Feeds

Return to page top